BTR5 freezes, Won't turn back on

A couple weeks ago, I purchased a Fiio btr5. It worked fine at first, but after just a couple of hours on Spotify the amp’s screen froze. I turned it off, but was unable to turn it back on afterwards. I tried all the troubleshooting tips listed on Fiio’s website, which were as follows:

  • Charging the amp with different chargers. Also tried different charging blocks.
  • Charging through the computer, then holding the power button
  • Leaving the amp for a few days, then charging and turning back on

None of these had any effect on the device. Eventually, I ended up returning it to the seller (Amazon) and ordering a new one. The replacement arrived today. However, not even 30 minutes into listening and the device has frozen again. I haven’t turned it off this time, so it’s stuck on the EQ/Hip hop screen. The computer is still connected via bluetooth, but when I play music there is no sound.

Has anyone come across similar issues with this? And more importantly, is there a way to solve this? I’m frustrated this has happened with both amps after minimal use, and a little concerned that Fiio’s support page has a troubleshooting page dedicated to this specific issue.

I had one that was pretty much DOA, I could charge it and the computer would recognize it was there, but it would play music or turn on. The only thing that maybe slightly useful I can say is that I found out that I needed to hold the power button for 30 seconds to reset the device instead of 10 like described in the manual.
That didn’t fix it for me though, hoping the next one won’t have a problem.

This has happened to me three times.

The first time I was listening to music and changing EQ settings…then the music kept playing, but none of the buttons would respond and evgen changing the volume on the phone had no effect.

The second time, music just cut out a couple of times, then the device stopped responsing with the screen off – I could only tell it was powered on because there was a pop when I unplugged my T2s and plugged them back in.

The third time was similar to the first–changing EQ settings made it crash.

Luckily, I have goitten it fixed all three times and the fix is the same.

Download the firmware/upgrade tool here:
https://www.fiio.com/newsinfo/360000.html

Their instructions are a bit hard to follow when the device isn’t working right, but here’s what I have found.

Plug it into the computer. You should get the animated charging bars for a short time. Hold down the multifunction button and volume up as they show, and it will briefly say “DFU mode” on the screen, but then it turns back off.

Now you should be able to flash the firmware, and it should work.

The most annoying part is verifying whether it is actually on or not to get it in a state where you can flash it. May need to hold the power button for a long time to turn it off and back on, but with no screen output a lot of times you’re just guessing.

This last time (just a few minutes ago), the exact sequence was

  1. BTR5 crashes
  2. Hold down power button for 30 seconds until it turns off
  3. Plug it into the PC
  4. Hold multifunction button + volume up until DFU appears
  5. Flash firmware.

I didn’t actually have to hit the power button to turn it on after I plugged it into the computer, so that part seems to be automatic.

It is possible that it won’t do this though, and the fix is to just leave it for like a day and then see if it gives the animated battery charging screen when you plug it in.

My conclusion is that the BTR5 has good sound, but you should never freaking mess with the EQ because it likes to crash.

Seriously thinking of getting an ES100 at some point just to see if it’s more reliable.

I recommend the qudelix 5k over the es100. The 5k has a peq.

It f*cking happened again! I was using it just fine, had it connected to my phone and laptop. All of a sudden the screen won’t turn on. Music was still playing though. So I figure I just reset the piece of crap by holding the power button of 10 seconds. Nothing, broken, kaput. I managed to get it fixed with @AxessDenyd 5 step plan luckily. I don’t think I will recommend the BTR5 to anyone though, it’s way too fragile.

Same exact issue here, this has happened multiple times with this buggy firmware and this is sadly the last time. Can’t even get it to go into DFU mode so I can reset the firmware. It’s always when I toy around with the in app Fiio EQ settings. So I guess this is the end of the BTR5 for me. Time to move on to something better and more reliable.

1 Like

Ah sucks to hear it’s not fixable anymore. I just had to flash the firmware again. It does indeed appear to have something to do with the EQ, they might want to improve their firmware/software skills before making a new device like they’re planning to…

Yeah it really is a shame though because this is among some of the best price/performance DAC/AMPs I’ve had with all the features it has. It punches pretty far up its weight class even with the weak-ish amp design on single ended. It just has too many firmware issues and I’ve heard enough people complain on and off Fiio’s own forums to the point that it is just plain negligence that these bricking issues haven’t been fixed by now.

First, follow those steps https://www.reddit.com/r/FiiO/comments/nvlve6/fiio_btr5_bricked_fix/
Second you have to make sure that it’s on before you hold the power button by putting device on wall charger and clicking the power button 5 times rapidly and if it didn’t go one you can hold it 5 times 2 sec each and then click it five times again while its plugged into wall charger through the usb cable that comes with device or and good cable and then you will plug you iem or headphone and by listening to your iem or headphone while you entering the jack into device, if it makes a crackling sound , that means its on , if it has no sound while you plug it or unplug it from device, that means it’s off and in this case you will have to click many times until it’s on ,after its on you have to has your iem or headphone with you plugged into device and you will push and hold on power button until you hear a click sound in your iem or headphone and after you hear it immediately push the vol+ and multifunction and it will go in dfu mood for sure, however you should push two buttons together immediately after hearing the small click sound from your iem , timing is the most matter , ive tried to do it a lot and i thought it’s toast device but oce you get the timing every thing will work fine and you have to has your iem pluged into your device from the moment it’s on -while the screen is off but entring iem makes crackling sound or peep sound or electricity sound- and til it enters the dfu mood and its not necessary to have to plunged into laptop until you have it into dfu mood and then you will do the rest of steps fine no issue

3 Likes

If all it seems to have happened is that the audio has stopped you might be able to fix it by simply unplugging the headphones and plug in them back in. I’m not sure why this happens but it happens on both of my BTR5’s. I don’t think this has anything to do with EQ because I use LDAC and the EQ doesn’t even work on LDAC so I’ve never used it. That said if I have to replace one of these things it will be a Qudelix 5K. Love sound, clips break, battery life really should be better, EQ is worthless to me and the glitches and temporary brick issues have just been too much for me to recommend this to anyone.

Hey there, have had the same issue happen to me but I cant seem to get the BTR detected in DFU mode at all.
Ive tried multiple usb cables, multiple pcs (win 11 and win 10) and nothing, doesnt show up in task manager or in the fiio update app.
I barely had the device a day, was switching between EQ’s and then poof, locked up on me, I hold power button to reset and it didnt turn back on.
Any ideas?