General Linux Thread

Then you can always use the setting in Pulse Audio version 13+ avoid-resampling = yes

 avoid-resampling=  If  set,  try to configure the device to avoid resampling. This only works on devices which
       support reconfiguring their rate, and when no other streams are already playing or capturing audio. The device
       will also not be configured to a rate less than the default and alternate sample rates.
1 Like

I don’t know why, either it did not work for me, or I used something similar in older pulseaudio versions when the “avoid-resampling” wasn’t available.

Also… I suspect this will cause all kinds of problems because if you pause a video on youtube, or start playing a 192khz song when two seconds of a youtube video is still playing in the background, with “avoid-resampling”, well, something will play slower/faster, or something will just break. I don’t think pulseaudio will immediately start to auto-resample the last 2 seconds of youtube-video in 192khz. With all the problems I had with pulseaudio (which I replaced with a 20-lines alsa config file…) I suspect it will just shit itself. :stuck_out_tongue:

With Deadbeef, set to “without any software conversions”, if something is playing in another bitrate, it just won’t play. You pause (or quit) the youtube video for bitperfect playback. It might be weird sometimes, but it’s the best way I’ve found to get reliable, bitperfect playback on linux, without any possibility of upsampling or downsampling.

And even with that I still don’t trust computers in general so I will get a DAC showing the Khz of the files playing, just to be 200% sure. :stuck_out_tongue:

I personally recommend the Holo Audio Spring 2… I’m not obsessed or anything.

1 Like

Also interesting, here’s a 5-channel waveform.

1 Like

Absolutely love Linux.

My audio player is cmus and I use cli-visualizer as well.

5 Likes

I really need to play around with cmus. Curses based interface for streamers are the way to go!

1 Like

My file explorer froze.
The joy of having to do… “sudo kill -9 2020.

Edit: Like, shutting down the year, not… killing more people. :grimacing:

6 Likes

Does anyone ever have problems hooking up a DAC through USB? I’m looking to buy my first DAC and was just wondering if there’s anything I should know before I go out and buy one.

Yes… Scroll up. All the info you need is in this thread to answer that exact question.

1 Like

Alright, thanks. Just wasn’t too sure if there was anything else.

To date, I’ve had zero issues with DAC’s and Linux. Everything I’ve plugged in has worked without me having to do anything at all.

3 Likes

So in case anyone else here is masochistic enough to want to stream Amazon’s Prime Video in 1080p on Linux (which they don’t directly support), the workaround I got results with is to play it in one of Microsoft’s Windows 10 virtual machines for Edge testing: https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

I used the VirtualBox one, where you also have to:

  • manually add a CD drive to the Win10 machine after importing it, otherwise you can’t “insert the VirtualBox Guest Additions CD” and enable high video resolutions
  • enable the audio device for the machine and set the controller to “Intel HD Audio”, then check Enable Audio Output
  • fiddle with some extra audio settings to make the playback more fluid in case you get some crackling
  • because playback wasn’t very smooth at first, I thought to go the machine’s Display settings and turn on 3D acceleration, which enabled double the video memory allocation as well (128->256 MB); that proved to be detrimental, as Edge would now flicker like a maniac and not be able to make up its mind about what page content should be displayed when; so then I unchecked 3D acceleration but the video memory was not cut back to the previous limit of 128 MB, so maybe this still helped a bit. It still doesn’t work straight up, I think the player might need some time to buffer enough data to play some sections(?) smoothly. Not sure how fluid this will all be in the end, still testing.
1 Like

Random youtube meme in my recommendations.

3 Likes

I pretty much hate any desktop music player that doesn’t look like Winamp, so I had to look real hard for one I could live with on Linux. What I found was this: https://vitux.com/how-to-install-qmmp-a-winamp-alternative-on-ubuntu/

After my latest round of Linux reinstalls (HDD/SSD trouble, don’t ask), I thought I would only be using this installation as a temporary, so I didn’t bother installing QMMP, especially since I don’t really listen from the PC much (fans still too noisy, rather listen from the phone while the PC is off). These days I just load music files up in VLC when I want a quick listen.

Lucky for me I still got the old xmms (one!) .deb file and required dependencies. :grin: For something more serious (full screen, customizable, bitperfect possible etc etc) I use deadbeef

1 Like

Welp. that was weird. Full system lock-up (debian linux), not even responding to alt+sysreq+reisub, and nothing in the logs. I already ordered a new drive that will be here in two days, perfect timing I guess.

…let’s do backups.

1 Like

Damn.

#1: If it’s not a “problem” for you, well, another problem is, it writes to the sources.list without asking.

#2: Quote: I noticed that this had been posted on the Raspberry Pi forums, but their moderators quickly locked + deleted the topic threads, claiming it was “Microsoft bashing.”

#3: Raspberry Pi CEO:

Regarding #3, it seems as if the RPi CEO has been living under a rock for decades and doesn’t understand *nix users relationship with Microsoft.

2 Likes

I just user Arch Linux ARM so… any ARM device I own doesn’t have issues like this.

2 Likes

So… you know what I used my USB 3.0 ports for, for like 10 years? Keyboard and mouse. I had so many problems with usb3 ports, I just considered em worthless and did not bother: usb2 always worked flawlessly anyway.

I used usb3.0 a bit lately, because my new external drive can do 100mb/s. But today, it would not even start… until I plugged it in a usb2 port.

Apparently, linux sometimes limits usb power. Search for “usbcore.suspend=0” and “usbcore.autosuspend_delay_ms=-1” parameters (I think?) to add to grub. After doing this, usb3 is fixed. Backup drive is even detected as a “superspeed” USB drive, even. I don’t even think I saw that before.

Also, SSDs are so cheap right now (and usb drives so unreliable…) I might order this:
https://www.amazon.ca/gp/aw/d/B07864V6CK/ref=ox_sc_act_image_4?smid=A3DWYIK6Y9EEQB&psc=1

and this:
https://www.amazon.ca/Sabrent-Boîtier-aluminium-NGFF-EC-M2MC/dp/B0765D6NJV/

(Or something similar) for a 500mb/s r/w external drive. Anyway, I’m ready for speed tests!

1 Like