Mac Mini & Amazon Music Unlimited

On my Samsung S23 my Amazon Unlimited account works perfectly. I get HD & UHD music without issue, even just streaming via Bluetooth in LDAC is sounds great.
So I’m logged into my Amazon Unlimited on my Mac Mini & all I can get is standard definition music. I open the settings & it tries to sell me Anazon Music I’m already paying for. Nowhere does it allow me to change the settings. The Mac Mini doesn’t allow me to change audio output settings either, using HDMI into my TV & optical out of it into one of my J2 DACs.
I just thought of something I haven’t tried. Maybe I can use USB as the audio out of the Mac Mini & just use HDMI for video on the TV. It’s getting too late to mess with it now.

A new day:
Why would using USB change anything? I’m not expecting this will fix the issue & I’m just going to have to be stuck using my phone for music listening. Reading through info on Amazon Music it appears only phones & tablets are devices they consider people to use for music listening. Oh I think they mention streamers maybe. They mention Android, Windows & iOS operating systems I believe. I don’t think they mean that as in computers like my Mac Mini.

Technology does not tend to do well around me when it fails at the simplest of tasks. What is the weak link? Amazon Music? Mac Mini? Visio TV? The TV must have it’s remote to be able to directly stream anything & the remote died a couple of days ago over night. New batteries made no difference. Having just set up my 8 year old Mac Mini to stream Amazon Video & YouTube on, both of which have HD content, I foolishly thought Amazon Music would just be like it is on my phone & I wouldn’t have to use Bluetooth & I wouldn’t have to keep switching my Bluetooth DAC from my desktop headphone system to my main speaker system.

I have to get ready for work. No time to mess with it now.

Some information from Amazon Music.
Any Mac from 2013 or later supports HD/Ultra HD. However, adjusting the default Mac audio settings is required to listen in the highest quality:

  1. Go to Applications/Utilities folder
  2. Open “Audio MIDI”
  3. Update speaker or headphone “Format” setting to the highest sample rate for 24-bit (96 kHz or 192 kHz)

Dont know for sure but the Mini might be issue here.
There was some information also that “if OS or hardware” is supported. It works.
Did not search more


Thanks. I’ll mess with it this evening & see what happens.

Thanks again.

Changed nothing. 24bit/48khz is the highest possible resolution & it changed nothing on Amazon Music. It still shows nothing but SD music.