Round 2... Sound not working after Sleep Mode

After installing audio drivers for Realtek and Nahimic, my audio still doesn’t work when I wake up my computer from sleep mode.

I used to have a stopgap measure where I switch from DAC (Schiit Unison Modius) to Realtek Digital Output (Realtek High Definition Audio) and back to DAC (Schiit Unison Modius) while playing music on Spotify.

Today, that stopgap measure does not work at all, and so I have absolutely no audio. This is a pain in the bum hole, since the new school semester has started, and I really need audio to work for my online classes.

for whatever reason, i have 2 Nahimic Mirroring Devices in my device manager. I uninstalled the one with the yellow triangle, and my audio worked just fine.

i put my computer to sleep, awoke it, and my audio is not working for DAC (Schiit Unison Modius) unless I do that stopgap measure. I check my device manager, and I have 2 Nahimic Mirroring Devices again, and one of them has a yellow triangle.

Why not remove/disable Nahimic completely.
There seems to many topics mentioned it being garbage and breaking every now and then from Updates and so on. Audio should work just fine with correct drivers only for Realtek and Schit device alone.

1 Like

How are you connecting to the DAC?

I have the Shcitt stack connected via USB and I have Disabled ALL other audio devices. I put my machine to sleep all the time with no issues.

  • Open Windows Menu, search ‘Sound Settings’ Open that
  • Check to see which Output device is being used in the drop down menu at the top (1)
  • You can go down to “Manage sound devices” - Try disabling all the other devices (2)

1 Like

Hello, thank you for the reply. There is a lengthy process I can do that is supposed to stop Nahimic & Realtek from operating in my computer. However, the moment I put my computer to sleep and boot up, Nahimic/Realtek is back in my computer.

Source: [FIX] Nahimic Companion keeps Reinstalling - Appuals.com

The thing is, I have to boot up my bios and disable my on-board audio. While that does get rid of Nahimic & Realtek completely, I cannot use my audio after sleep mode. As a result of disabling my on board audio, I also cannot use my stopgap measure of flip flopping betweeen DAC → Realtek → DAC, just to make audio work.

Hello, thanks for the reply. I have my Schiit Modius connected via USB. However, I’m not sure if I myself have all of my audio devices disabled.

I have a similar problem, but not quite as serious. I am using my laptop as a jukebox to feed my Schiit BF2, via USB. If my laptop goes into sleep mode at all it will not play sound from iTunes after waking up and I have to re-boot the program. Not a major problem, but a little annoying.

1 Like

Look’s simple to me.
Just remove the nahimic and leave / reinstall a clean Realtek one.

If i remove nahimic and put my computer to sleep, naimic will be reinstalled the next time i boot my computer

You probably did not remove it completely then, driver folders and stop services etc like information suggests. Simple uninstall does not remove it. The OS knows to look for devices, if it’s not completely removed. It will be found again and again.

When nothing is to be found. It will not find anything.

Okay but if i disable my on board audio via bios then i will be left with my dac, meaning realtek audio is no longer in sight. In spite of that, if I boot up my computer, my audio still has no audio

Of course.
That’s why you need to focus on Nahimic device only and remove it… not disable all the audio.
Two very different things.

Try the information you linked.

And dont do anything else. :slight_smile:

I did follow those instructions. But when I put my computer to sleep and wake it up, Nahimic has itself reinstalled as if it was malware.

okay, for whatever reason, i followed the steps from the website, uninstalled realtek, reinstalled realtek, and no more nahimic. i’m guessing i needed to do the uninstall & reinstall steps JUST for realtek

but now, just like always, i STILL have no audio playing for DAC (Schiit Audio Modius) after i wake my computer up from sleep mode.

Fixing the Realtek back to working might just solve it.
OS audio side usually works but if it’s the schit side.

They have a separate information for issues, if it would help.
https://www.schiit.com/guides/usb-problems

There also are many topics what you can try. “Search: windows 10 sleep mode no audio”
But i wont be going in more details about OS audio issues/fixes.

Hello everybody, I have a positive update. As it turns out, the Spotify player was the root of all this trouble. If I put my computer to sleep with the Spotify player active, then I need to use the DAC → Realtek → DAC shuffle to make my audio work on my next computer session.

If I quit/exit the Spotify player completely before I put my computer to sleep, then I do not need to use the DAC → Realtek → DAC shuffle to make my audio work.

Another interesting thing about that shuffle: I need to play music on Spotify, because the shuffle does not fix my audio if I watch a Youtube video, or listen to music on Soundcloud’s website.

1 Like