Topping D30 Output

I recently purchased a D30 and I haven’t gotten it to work just yet. Initially I suspected the culprit to be the drivers (Win 7). However, I’ve downloaded them straight from Topping’s website. I’ve even uninstalled and then reinstalled them to make sure I did it correctly. Nothing. I currently use Foobar to play my music but nothing will play even if I use iTunes. The red light for “Unlock” is off. So then, the computer recognizes the DAC. I’ve used different pairs of cables to output to my Loxjie P20. I’ve got the correct input set on my P20 as well. I read that I’d have to have the volume at %100 on my computer for it to work but that hasn’t been the case. All in all, I think the female RCA connections on my D30 are no good. Any suggestions/solutions?

Have you checked the sound preferences…'Output Devices? on a Mac it looks like this…


I change lot of different outputs and sometimes the solution is just a click a way?

1 Like

You probably already know this but It does not hurt to tell you this. Right click the speaker icon by the clock at the bottom right. After that click sound. That should give you a small widow with a tab control. Then click the playback tab. You should see the Topping D30 in the list. Set the Topping D30 as default. Play something on your music app. You should see a sound meter by the Topping D30 go up and down. If you see the volume meter go up and still no sound. Check you app to see if you did not mute the sound on it.
Windows has a volume mixer. To see it right click the speaker icon by the clock again and select Open Volume Mixer. See if your device or app is not muted. It has a speaker icon at the bottom of each app that makes sound.


Thanks for the responses guys; I appreciate it. Sadly, those solutions did not work. I’ve made sure that I’m outputting to the correct device. I’ve also set the D30 as the default sound device. I do see the meter by the D30 go up and down but still have no sound. In Foobar the device is selected and not muted. I wonder what it could be… If anything else comes to mind, don’t hesitate to reach out. Again, thanks.

I sure you are doing it correctly, but the only think I can think of is the input selector of the DAC is selected to the correct input. For example, If you are using USB then select USB.
My Schiit Modi acts up sometimes and I cycle through the inputs and that fixes it somehow.

1 Like

Can you try testing it with the optical input? If it still doesn’t work then, your device must just be defective. Also you did confirm with a different device your amp input was working right?

1 Like

Thanks again guys.
Yes, I cycled through the inputs. No luck.
Also, the RCA inputs on my P20 work just fine. I verified that connecting unbalanced with my SU-8. Furthermore, the optical didn’t work out for me either. Sadly, I think it’s a defective unit.