Usb dac for Nintendo Switch

Does anyone know of an affordable dedicated usb dac that can work off the Nintendo Switch dock or otg USB? I have my dock hooked up to my monitor but it doesn’t have a spdif output. The dac I use for my pc is usb only but doesn’t work for the switch.

Would the Fiio BTR5 work?

Some usb dacs work and some don’t, if I recall correctly with an otg cable the fiio q1 mk2 worked so the btr5 might work

This has me curious. I’m going to try and plug in some of my stuff to my switch when I get a chance.

I have a BTR5, and I can’t seem to get it to work. The BTR5 will say “44.1”, indicating it’s taking a USB source, but the switch doesn’t use it. Which is weird, because I recently bought a USB Bluetooth transmitter (with aptX LL). It will work fine when it’s plugged into the dock, then it’ll use USB audio, but I’ve only gotten it to work in the dock. I haven’t tried the straight BTR5 in the dock to see if it’ll work there. So far no USB audio on the handheld switch.

This is just my experience btw, no research or anything. And I only have a BTR5 and this Chinese Bluetooth transmitter to test with for USB audio

I have the q1 mkll and it didn’t work, with any cables I tried.

What cables did you use? I used this otg cable and it worked, but idk

I use this amazon basics cable and it works with my phone but not my switch

Yeah idk, fiio can be picky with cables at times, so I’m not sure. Could also be a switch firmware/version thing

I use a switch Lite and I was unable to find a DAC that works, so I use the below USB Bluetooth adapter and then use my BTR5. It sounds much better than the headphone out.

What about this:

1 Like

Finally got around to trying out the radsone earstudio es100, and I can confirm it works perfectly with the switch and this cable:

BoTW never sounded better, es100 balanced to 58x :grin:


Well @ELACaster there you go! :smile:

Just to be thorough, I tried the other portables that I have. Both the monoprice thx aaa portable and the fiio q1 (1st Gen) do NOT work with the switch with the same cable I used with the es100.

1 Like

I purchased that cable and it doesn’t work.

Interesting, how recent did you buy your switch?

I got my switch at Launch.

Hmmm, I did as well, I wonder why it’s not working then

Maybe there’s internal variations with the q2 mkII depending on when they were purchased? Honestly kind of feel like that’s the most likely culprit.