Requesting some quick DAC setup help

I was doing some experimenting and hoping to place a DAC in between my TV source to my AVR and stream Amazon HD using my TV app.

So I selected HDMI video, but Optical audio on my TV, have a optical cable to my SMSL M100 DAC, and placed RCA cables (in which I unplugged my LR from my input 1 and placed it to input 6) to my LR speakers . When I played the music, no music came out, but this weird “digital static” sound came out? Did I do something wrong? Wrong settings? Or is this not a possible setup?

I am going to try this one more time this afternoon with my Zone 2 inputs instead and see if that works better.

You most likely have to switch the output mode of optical to PCM in the tv

What model of TV is it?

I’ll double check that.
Samsung NU8000. I’ll also double check my settings on the Onkyo AVR – I know the settings can be super finicky on it.

So make sure you are on the specific input on the TV you are using, then go into audio settings and make sure it is set to pcm

This might help you out perhaps

1 Like

Cool, I’ll mess around with the settings this afternoon. I just didn’t want to be messing around with something that was “impossible” or not suggested to do. I just wanted to try to use my AVR as my amp while I am waiting for my MP-301.

Nice, a very similar setup. Thanks again for your help. I am fairly confident that I should be able to get it to work this afternoon.

Unfortunately, this solution didn’t work for me this afternoon. I no longer get the static noise, but now I just get no sound at all.
I selected Optical Sound on my TV – I checked the digital audio out and selected PCM. I went to my AVR and selected all PCM as well. Again, no static, but no sound =/

Was it on the right input and show anything that would signify that it was receiving audio?

I want to say yes?
As mentioned earlier, I set my TV audio to Optical, set my DAC to receive optical, plugged RCA to CD/Audio 5 on my AVR and set my AVR to CD. On bitstream, I was getting the static mentioned earlier, but now on PCM, I receive nothing.

I am assuming there is still some setting error, because the PCM icon is blinking on my AVR, but I’ve messed around with the settings for 30-40 minutes to no avail.

Well the avr shouldn’t be getting any digital signal because the m100 should be converting the signal to analog and passing it on to the avr through rca

Try directly connecting the optical to the avr from the tv and see if you get sound

Without using the DAC?
As in to check if the optical cable and the inputs/outputs work? Yes, I get sound through optical when I do TV to AVR to speakers.

Ok, so the smsl is the culprit then, are you sure that you have the correct input?

I cycled through all three inputs, yes. 1 is USB, 2 is optical, 3 is coaxial which I don’t own an extra cable.

So on coax mode there is no output on the m100?

I cannot tell since I don’t have an extra cord to check.
I’ve tested USB on my headphone amp and that part works fine. It powers on fine as well and the bitrate display seems to change depending on the song and output.

I hope the optical port isn’t faulty. I’ll check to see if I have any open optical slots on my PC to check w/ my headphone amp again.

Yeah, also make sure you are on the input on the tv and check again to make sure it is still on pcm. I would try and see if optical from your pc would work on the m100

Going to be mad if this is the solution, but do I need to turn off all of my ARC/CEC settings?

You shouldn’t, but you can try. I have not heard of that being an issue unless you had an arc device that was currently in use and preventing optical output, but that would be pretty strange

I have confirmed that both the optical cable and the port on the m100 is working fine on the pc.
Man, if this pisses me off enough, I’m just going to stream music off of my laptop (to DAC to mp301) rather than fuss with my TV